SAML Configuration on Agile 9.3.5

Hi All,

We are trying to configure SAML authentication in Agile 9.3.5 and we are stuck at a point where i need your insights/help. 

We have done various configuration changes in the Weblogic for SAML Identity Asserter, Service Providers,IP Providers and authentication order. 

After performing all this configurations we are able to get our IAM login page. However once we login it gives us Error 403. (I have attached the image here) 

Please let me know your suggestion or in-case someone have implemented it. 

Regards,
Arif

No Files Were Attached
Arif Agile Angel Asked on October 13, 2017 in Product Collaboration.
Add Comment
2 Answer(s)

As per the Oracle updates it seems Agile still don’t support SAML directly, but only via web services. If you wants to use SAML this can be done only via web services and not via web client. 
Has anyone tried it. Also attaching the list of steps we followed for configuring on weblogic based on few blogs we came across. 

Request you to share if you have any info.

Arif Agile Angel Answered on October 20, 2017.
Add Comment

Hi All,

Finally Agile – SAML integration is working for us. After entering network credentials finally SAML url is redirecting it back to Agile URL. All this is achieved through weblogic configuration changes. 

Once you are done with basic configurations, then much has to do with the ordering of providers, The ordering that worked for me was : 

1. SAML 2.0 Identiry Assertion Provider  2. Weblogic Authentication Provider (Your default) 3. Agile Authentication Provider 4. Provider that performs LDAP Authentication 
5. Trust Service Identity Assertion Provider. 

Regards,
Arif

Arif Agile Angel Answered on November 3, 2017.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.