Need help with Oracle Agile PLM

I am facing an issue using one of the customized URL PX in our Agile PLM implementation. The functionality of the PX is to export a set of attributes into a .xlsx workbook. The functionality works fine with Chrome and Mozilla web browser and export all the required data in .xlsx file. When I try the same in IE, I see the data does gets exported but the excel come out to be in. xls format. This is happening specifically in IE only. The code of the URL PX does not contain any browser specific handling and I am using XSSFWorkbook format from poi.jar (Java API).

Can anyone help me what could be a possible reason for this?

No Files Were Attached
tapan Agile User Asked on September 27, 2017 in Product Collaboration.
Add Comment
3 Answer(s)

Hi,
This is not really related to Oracle Agile PLM.
Which is the Content Type format that you are using to download the file? each browser, has the default File Type association configurable browser by browser

For Example:

Response.ContentType = "application/application/vnd.openxmlformats-officedocument.spreadsheetml.sheet";
Response.AppendHeader("content-disposition", "attachment; filename=myfile.xlsx");
Antonio Agile Angel Answered on September 27, 2017.

I am using the below:

response.setContentType(“application/vnd.ms-excel”);
response.setHeader(“Content-Disposition”, “attachment; filename=” + fileName);

where fileName contains <Name>.xlsx

on September 28, 2017.
The application/vnd.ms-excel is .XLS
In some browser version, it could happen that the file is downloaded myfile.xlsx.xls

Try to use the one below:

response.setContentType("application/application/vnd.openxmlformats-officedocument.spreadsheetml.sheet");
response.setHeader("content-disposition", "attachment; filename=myfile.xlsx");

The filename xlsx is not enough
on September 28, 2017.
Add Comment

I suspect it is the default contenttype as well for IE. check internet about that. Also make should you are not running IE in compatibility mode. That will make it run as if it were IE 8.

Steve Jones Agile Angel Answered on September 28, 2017.
Add Comment
Best answer

Thanks Antonio and Steve for your suggestions.
I found a solution which is mentioned below and it worked out for me. I had to change the registry setting for IE.

Windows -> Run -> regedit 
HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-excel\Extension
 and changed .xls. to .xlsx.

tapan Agile User Answered on September 28, 2017.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.