When users try to call an external RESTFUL Web Service within Agile session, it fails.

I tried that solution provided by Oracle, but It didn’t work.
Please provide  me any other solution for that.

oracle doc id 2195810.1
When users try to call an external RESTFUL Web Service within Agile session, it fails.

 
STEPS
1. Write a PX and invoke the RESTFUL Web service.
2. The web service invocation fails with error:Class not Found weblogic.security.SSL.jsseadapter.JaSSLContextImpl
 
APPLIES TO:
Oracle Agile Product Collaboration – Version 9.3.4.0 and later
Information in this document applies to any platform.
 
<11 Jan, 2019 3:12:50 PM IST> <Info> <Security> <BEA-090905> <Disabling the CryptoJ JCE Provider self-integrity check for better startup performance. To enable this check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true.> 
<11 Jan, 2019 3:12:50 PM IST> <Info> <Security> <BEA-090906> <Changing the default Random Number Generator in RSA CryptoJ from ECDRBG128 to HMACDRBG. To disable this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true.> 
Exception in thread “main” java.lang.IllegalArgumentException: [Security:090461]Class not Found weblogic.security.SSL.jsseadapter.JaSSLContextImpl
at weblogic.security.utils.SSLSetup.getDelegateClass(SSLSetup.java:143)
at weblogic.security.utils.SSLSetup.getSSLDelegateInstance(SSLSetup.java:100)
at weblogic.security.utils.SSLContextWrapper.<init>(SSLContextWrapper.java:71)
at weblogic.security.utils.SSLContextWrapper.getInstance(SSLContextWrapper.java:62)
at weblogic.security.utils.SSLSetup.getSSLContext(SSLSetup.java:365)
at weblogic.security.utils.SSLSetup.getSSLContext(SSLSetup.java:357)
at weblogic.security.SSL.SSLClientInfo.getSSLSocketFactory(SSLClientInfo.java:104)
at weblogic.security.SSL.SSLSocketFactory.setSSLClientInfo(SSLSocketFactory.java:241)
at weblogic.security.SSL.SSLSocketFactory.<init>(SSLSocketFactory.java:44)
at weblogic.security.SSL.SSLSocketFactory.getInstance(SSLSocketFactory.java:77)
at weblogic.net.http.HttpsClient.getInternalSocketFactory(HttpsClient.java:262)
at weblogic.net.http.HttpsClient.openServer(HttpsClient.java:271)
at weblogic.net.http.HttpsClient.openServer(HttpsClient.java:361)
at weblogic.net.http.HttpsClient.New(HttpsClient.java:564)
at weblogic.net.http.HttpsClient.New(HttpsClient.java:545)
at weblogic.net.http.HttpsURLConnection.connect(HttpsURLConnection.java:236)
at weblogic.net.http.HttpURLConnection.getInputStream(HttpURLConnection.java:685)
at weblogic.net.http.SOAPHttpsURLConnection.getInputStream(SOAPHttpsURLConnection.java:41)
at java.net.URLConnection.getContent(Unknown Source)
at com.domainsi.siliconexpert.businesslogic.BusinessLogic.getSEDetails(BusinessLogic.java:133)
at com.domainsi.siliconexpert.main.SiliconExpertMain.main(SiliconExpertMain.java:30)
Caused by: java.lang.ClassNotFoundException: weblogic.security.SSL.jsseadapter.JaSSLContextImpl
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at weblogic.security.utils.SSLSetup.loadDelegateClass(SSLSetup.java:158)
at weblogic.security.utils.SSLSetup.getDelegateClass(SSLSetup.java:130)
… 20 more
 
Solution Given as per oracle docs
1. Open the Application Server startup script.
2. Add the below Parameters in the Application Server Start command, for Cluster add the same in startup scripts of all Managed Servers.
 
-Djava.protocol.handler.pkgs=com.sun.net.ssl.internal.www.protocol
-Dssl.SocketFactory.provider=com.sun.net.ssl.internal.SSLSocketFactoryImpl
-DUseSunHttpHandler=true -Dweblogic.wsee.client.ssl.usejdk=true
3. Restart the server.
4. Retest the issue.
 
 
Question is where exactly I need to put these parameter in StartWeblogic.cmd

Thanks 
Sandeep

Add Comment
1 Answer(s)

look under agileDomin/bin folder
add the -Doptions to the end of JAVA_OPTION in whatever sh / cmd that is used to launch your A9

Agile Talent Answered on March 23, 2019.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.